Hyundai IONIQ Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
204 Posts
Discussion Starter · #1 ·
I have a 2022 US Ioniq 5 Limited with ~20k miles running November 2022 firmware.

A couple of weeks ago, I lost the ability to listen to AM/FM/XM radio. Specifically, when I push the Media button, the car start playing the bluetooth/carplay/sounds of nature media sources, depending on what is connected. If I repeatedly press the media button, the media selection menu does come up, but when I pick FM, AM or XM, the system hangs for a second and then starts playing bluetooth/carplay/sounds of nature. All of those media sources play normally, it seems that it's just anything using that radio app that is affected.

So far, I have tried:
  • Reboot using the pin hole
  • Disconnect the 12V
  • Update from October to November software (I updated before the October version was pulled)
  • Read DTCs with CarScanner, nothing radio-related, just P0C17 that's present on many Ioniq 5s and some power assisted steering codes leftover from dealer replacing the clockspring (radio functioned after that).

A couple of additional observations:
  • Onset was random - not correlated with an update, service, etc. Just started one morning.
  • If I pick FM as a source and quickly reboot before it starts playing another source, after the infotainment system boots up, then the FM radio plays fine, suggesting this not the antenna/tuner connnectivity issue. However, the head unit still does not display the radio screen and if I press the Media button, it starts paying another source.

Made a service appointment in a couple of weeks. Meanwhile, here's the obligatory "has anyone seen this/any other ideas?"
 

· Registered
Joined
·
204 Posts
Discussion Starter · #2 ·
Jus a quick update that the dealer wasn’t able to diagnose it more specifically than “something up with the headunit”. They will be ordering a new headunit.
 
  • Like
Reactions: zamafir

· Registered
Joined
·
3 Posts
I have the exact same issue and it began around the same timeframe as yours. I reset the display using the pin hole button, and also did a full factory reset, neither of which helped.

I have an appointment in 3 weeks to get it looked at (and the preconditioning update applied). Disappointing to hear that ordering a new head unit is all your dealer could come up with.

Edit: 22 Limited delivered in March 2022.
 

· Registered
2022 Ioniq 5 Limited AWD Cyber Gray
Joined
·
796 Posts
Just an FYI you can press and hold the Media button to get the menu to come up, you don't have to keep pressing the button.
 

· Registered
Joined
·
3 Posts
No, that doesn't work for me. Pushing the media button won't bring the screen up at all, and the screen starts to glitch out. I have been able to get to Bluetooth audio by first using Android Auto, but otherwise the button doesn't work. It will also sometimes default to Sirius XM, but is stuck in the demo channel even though I have a subscription.
 

· Registered
Joined
·
204 Posts
Discussion Starter · #7 · (Edited)
Just an FYI you can press and hold the Media button to get the menu to come up, you don't have to keep pressing the button.
No, I can’t - it immediately freezes the headunit.

It will also sometimes default to Sirius XM, but is stuck in the demo channel even though I have a subscription.
No SXM subscription in my case, but it does sometimes switch to SXM and play the radio ID channel.

Further, ifI reboot the headunit at just the right time after attempting to run the radio app, I can get the FM radio to come through and the reception is clear. So it’s likely not an issue with the actual FM receiver/antenna hardware. But I still cannot switch stations or get the radio app up.
 

· Registered
Joined
·
3 Posts
Further, ifI reboot the headunit at just the right time after attempting to run the radio app, I can get the FM radio to come through and the reception is clear. So it’s likely not an issue with the actual FM receiver/antenna hardware. But I still cannot switch stations or get the radio app up.
Your issues are identical to mine. Given that they started around the same time, it is clearly a software issue. I have reinstalled the most recent update (via USB), but that did not solve it. I don't have much hope that the shop techs will be able to fix it either....
 
1 - 8 of 8 Posts
Top