Hyundai IONIQ Forum banner
741 - 760 of 820 Posts

·
Registered
Ioniq Non-plugin hybrid
Joined
·
74 Posts
Great - but the download link is brain-dead. It won't let me download the software because I'm using Fedora Linux!
 

·
Registered
Joined
·
1 Posts
It's 2022, this should be OTA as default with images as backup. An average consumer would struggle with these updates.
 

·
Registered
Kia Xceed 1.5 4 DCT MY20
Joined
·
11 Posts
I have a Kona EV and an i30 diesel, both with the latest Dec 2021 version of the infotainment software. I have been struggling with the ‘- - -‘ on both. As it was really bad on the i30 today, I relented and pushed the little reset button on the front of the screen. After rebooting and a couple of minutes later everything is back to normal and I have speed limits again. Not sure if this will sort long term but it certainly seems to have worked for now. Going to try it on the Kona over the weekend…. Fingers crossed 🤞
I gave this a try myself and it did solve the problem for 24h but it returned the next day.

Does anyone know if its possible to revert to a pre 211117 version and where I could find the files I would need?
 

·
Registered
Joined
·
1,208 Posts
Discussion Starter · #746 ·
I gave this a try myself and it did solve the problem for 24h but it returned the next day.

Does anyone know if its possible to revert to a pre 211117 version and where I could find the files I would need?
the problem for the "---" seems to be when hyundai/kia switched from HERE maps to TOMTOM maps.
People are also saying that when you download Here app and AmiGO by TomTom app on your phone the AmiGO app is showing "---" speed limit in the same areas as the car while Here app is showing proper speed limits.

its possible to downgrade, the process is simple. i jsut cant remember at the moment which version/month they still had HERE maps. i have all the versions on my gdrive
 

·
Registered
Kia Xceed 1.5 4 DCT MY20
Joined
·
11 Posts
the problem for the "---" seems to be when hyundai/kia switched from HERE maps to TOMTOM maps.
People are also saying that when you download Here app and AmiGO by TomTom app on your phone the AmiGO app is showing "---" speed limit in the same areas as the car while Here app is showing proper speed limits.

its possible to downgrade, the process is simple. i jsut cant remember at the moment which version/month they still had HERE maps. i have all the versions on my gdrive
Hello @SonicSpinner Thanks for your reply.

Yes I have used AmiGo and you are quite right it shows '---' when it doesn't know the speed but Here tends to show 20mph. AmiGo also gives me incorrect speed limits in places that Here does not. But the 21117 update also introduced other bugs which seem to be something to do with initialising the HU when the car is started, if you 'reset' the HU this goes away for a short while but returns again.

I have the Standard Gen5 Wide HU and I am certain the Here maps were used on the 210303 version using EUR.13.47.47
412.407.2(D.H2) maps

And I think Here was still used in the 210817 version using EUR.14.41.41.657.401.2(D15) maps
 

·
Registered
Joined
·
5 Posts
I reverted from the November 2021 updates to the August 2021 (MIX_S5W_L_210817_MAP_14_41_42_585.zip) release on my car and that has proved to be pretty stable and issue free.

You can go backwards on the releases, will leave SonicSpinner to explain.
 

·
Registered
Kia Xceed 1.5 4 DCT MY20
Joined
·
11 Posts
the problem for the "---" seems to be when hyundai/kia switched from HERE maps to TOMTOM maps.
People are also saying that when you download Here app and AmiGO by TomTom app on your phone the AmiGO app is showing "---" speed limit in the same areas as the car while Here app is showing proper speed limits.

its possible to downgrade, the process is simple. i jsut cant remember at the moment which version/month they still had HERE maps. i have all the versions on my gdrive
I'm currently downloading EUR.MIX_5W.EUR.S5W_L.001.001.210817_map_14.41.42.585.zip. I've had a good look around the forum (clearly not well enough though :rolleyes: ) but can't find the instructions to load it, could you please point me in the right direction
 

·
Registered
Joined
·
1,208 Posts
Discussion Starter · #750 ·
the process is simple
find your current update installtions files. there are 2 files in the root called
Appupgrade and .lge.upgrade.xml. copy these 2, and place them in the older update installation files and replace the existing files.
now copy all everything (the older update ) , to the usb and insert it into the car.
the car will state that you allready have the current update, do you wish to continue, you choose yes. and do a quick update. Voila.

here is a link to the august update which martin tried


and here is a link to the 210303, which you mentioned. try and see which one solves your issue

 

·
Registered
Kia Xceed 1.5 4 DCT MY20
Joined
·
11 Posts
the process is simple
find your current update installtions files. there are 2 files in the root called
Appupgrade and .lge.upgrade.xml. copy these 2, and place them in the older update installation files and replace the existing files.
now copy all everything (the older update ) , to the usb and insert it into the car.
the car will state that you allready have the current update, do you wish to continue, you choose yes. and do a quick update. Voila.

here is a link to the august update which martin tried


and here is a link to the 210303, which you mentioned. try and see which one solves your issue

Thank you so much, I will try it later when the download has completed 😁
 

·
Registered
2020 Ioniq 38 EV
Joined
·
111 Posts
I gave this a try myself and it did solve the problem for 24h but it returned the next day.
I also tried the reset button which at first did solve the "---" problem, but the next day the dreaded dashes were back. It seems intermittent the dashes disappear and show the correct speed limit then the dashes re-appear randomly?
 

·
Registered
Kia Xceed 1.5 4 DCT MY20
Joined
·
11 Posts
the process is simple
find your current update installtions files. there are 2 files in the root called
Appupgrade and .lge.upgrade.xml. copy these 2, and place them in the older update installation files and replace the existing files.
now copy all everything (the older update ) , to the usb and insert it into the car.
the car will state that you allready have the current update, do you wish to continue, you choose yes. and do a quick update. Voila.

here is a link to the august update which martin tried


and here is a link to the 210303, which you mentioned. try and see which one solves your issue

Just to double check, there is no chance of doing any damage doing this is there?

I also note that in the official files there is one called Xceed_Ceed_CUV_MY20_EU which seems to contain a list of the files on the update but your files have an MD5 file instead containing something similar, presumably these are not used by the system, is that right?
 

·
Registered
Joined
·
1,208 Posts
Discussion Starter · #754 ·
Just to double check, there is no chance of doing any damage doing this is there?

I also note that in the official files there is one called Xceed_Ceed_CUV_MY20_EU which seems to contain a list of the files on the update but your files have an MD5 file instead containing something similar, presumably these are not used by the system, is that right?
nope, ive been downgrading and upgrading many many times, no problem at all.
the md5 or .ver file is not used by the system, correct
 

·
Registered
Joined
·
22 Posts
My understanding is that the '- - - ' appears until the TomTom system passes a known area with a speed limit.

I have a UK spec Santa Fe PHEV which reads the speed limit signs, and generally it will pickup the speed once you pass the first set of signs.

Does the '- - - ' problem go away after driving a short period? I know there was a problem at one point where TomTom would not show speed limit info (on their normal devices) until there was a good satellite lock received.

I do have a different problem (one of those things) that if you drive past a truck which displays speed limits on the back of the vehicle (thing in EU/ UK) the camera picks up the speed limits from that truck. Not really an issue, but can cause havoc when you're on HDA and it changes the speed limit for you to the new limit on the truck!

I've also noticed the camera misread dirty signs (80mph anyone - in a 30mph zone!) too which can be fun.

At the end of the day, you pay attention to your surroundings and drive the car, ready to take over control or cancel whatever system is coming up when it happens so that it doesn't affect you. You are after all, the one in control...
 

·
Registered
Kia Xceed 1.5 4 DCT MY20
Joined
·
11 Posts
My understanding is that the '- - - ' appears until the TomTom system passes a known area with a speed limit.

I have a UK spec Santa Fe PHEV which reads the speed limit signs, and generally it will pickup the speed once you pass the first set of signs.

Does the '- - - ' problem go away after driving a short period? I know there was a problem at one point where TomTom would not show speed limit info (on their normal devices) until there was a good satellite lock received.

I do have a different problem (one of those things) that if you drive past a truck which displays speed limits on the back of the vehicle (thing in EU/ UK) the camera picks up the speed limits from that truck. Not really an issue, but can cause havoc when you're on HDA and it changes the speed limit for you to the new limit on the truck!

I've also noticed the camera misread dirty signs (80mph anyone - in a 30mph zone!) too which can be fun.

At the end of the day, you pay attention to your surroundings and drive the car, ready to take over control or cancel whatever system is coming up when it happens so that it doesn't affect you. You are after all, the one in control...
The way a Speed Limit Information Function (SLIF) with a camera is intended to work is the current speed limit from the map data is shown unless this is superseded by the camera. In this way you should always have the correct speed limit, including temporary limits, shown on the dash.

What is happening on some cars after the November update is the HU seems unable to determine the correct speed limit at start up so shows '---', this is then superseded with the correct speed either when the car passes a speed sign or the Nav informs it of a speed limit. Another occasion where '---' is shown is where the Nav data does not have a speed for a particular stretch of road which seems to be reasonably frequent with TomTom maps as opposed to Here maps.
 

·
Registered
Kia Xceed 1.5 4 DCT MY20
Joined
·
11 Posts
Thank you so much, I will try it later when the download has completed 😁
Mmmm, well it installed ok but I don't have any vehicle settings, such as reversing camera, road speed on Nav screen and some I haven't found yet.

I note that the s/w & maps versions haven't changed, is this as expected?

I am retrying the installation but do you have any suggestions?
 

·
Registered
Kia Xceed 1.5 4 DCT MY20
Joined
·
11 Posts
Mmmm, well it installed ok but I don't have any vehicle settings, such as reversing camera, road speed on Nav screen and some I haven't found yet.

I note that the s/w & maps versions haven't changed, is this as expected?

I am retrying the installation but do you have any suggestions?
False alarm, I loaded it again and all seems well except the HD speed limit seems to be kph
 

·
Registered
Kia Xceed 1.5 4 DCT MY20
Joined
·
11 Posts
I loaded 210817, it seemed to install ok but when I went back to the car it was asking something about updating so I just hit OK and it seemed to install something else for about 5 mins then went to the map screen. I checked the versions and they hadn't changed from 211214. So I updated again and then had 210817 with 30mph on the cluster & 18 on the HU. I switched it all off and reset the HU and now have '---' again and a low horizon on the map. I suspect that this version might still have TomTom maps so I will test it tomorrow to find out but in the meantime I'm downloading your 210303 version.

It's in hand sort of 🤣
 
741 - 760 of 820 Posts
Top