Hyundai IONIQ Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
New to this forum, but have found answers to all my other questions so far...Thanks!

Driving a 2017 28kW Ioniq Electric. It is my first EV so no idea what I'm dealing with.

Bought in November, second hand, have had the car in the garage twice now for the same 'problem'
The green 'ready to drive' light flickers when regenerative braking is happening. ie. when I release pressure on the accelerator. Usually when it gets to two blue bars. I'm driving at Level 3 Regeneration.
Originally I decided it was an issue because 4 times in a month taking off from a roundabout after a gradual slowdown the car had NO power. Pumped the accelerator, nothing. Put the car in park, then tried drive again and it worked.

The garage each time has sent the car back saying it is 'fixed', the second time they replaced the 12V battery. The week before it was dead and the AA told me it needed changing so I trust that was necessary.

The NO power issue hasn't happened since the 12V battery was replaced two weeks ago, but the flicker on Regen is incessant, but somedays worse than others. There seems to be no connection between the charge on the battery, or how long ago it was plugged in - I've kept notes.

Each time they've returned the car, regenerative braking is switched off. So either they didn't see the fault, or are choosing to ignore it...
I'm starting to wonder is it just meant to flicker!?
Any advice?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for that. Power failure at a roundabout again today. Car booked back in on Friday. Mentioned the earth strap cable and he said they did that before to solve a more extreme problem...hopefully they'll try it anyway...
Appreciate the link.
 
1 - 3 of 3 Posts
Top