Hyundai IONIQ Forum banner
1 - 20 of 202 Posts

· Registered
Ioniq EV Premium SE 38.3kWh
Joined
·
109 Posts
Discussion Starter · #1 ·
Just started my car and as I drove off got a yellow icon taking up the whole instrument display saying "refill coolant". Couldn't dismiss it from the display, would reappear after a few seconds. Car was serviced 5000 miles ago so should be in good condition.

A few minutes down the road I reached red traffic signals, so I turned off the car while waiting, then turned it on again. Message did not repeat for the rest of the 8 mile journey home.

At home I checked the coolant level. My driveway slopes downwards slightly so coolant was not level in expansion tank but it was well between the low and high levels, slightly nearer high in fact.

Anyone seen this before? Hopefully just a glitch but maybe a sensor going bad?
 

· Registered
Joined
·
2 Posts
Just started my car and as I drove off got a yellow icon taking up the whole instrument display saying "refill coolant". Couldn't dismiss it from the display, would reappear after a few seconds. Car was serviced 5000 miles ago so should be in good condition.

A few minutes down the road I reached red traffic signals, so I turned off the car while waiting, then turned it on again. Message did not repeat for the rest of the 8 mile journey home.

At home I checked the coolant level. My driveway slopes downwards slightly so coolant was not level in expansion tank but it was well between the low and high levels, slightly nearer high in fact.

Anyone seen this before? Hopefully just a glitch but maybe a sensor going bad?
Had exactly the same experience last week. Mine was serviced 3000 miles ago.

Hasn't come back on since

Ioniq 38kwh 2020
 

· Registered
Joined
·
64 Posts
Just started my car and as I drove off got a yellow icon taking up the whole instrument display saying "refill coolant". Couldn't dismiss it from the display, would reappear after a few seconds. Car was serviced 5000 miles ago so should be in good condition.

A few minutes down the road I reached red traffic signals, so I turned off the car while waiting, then turned it on again. Message did not repeat for the rest of the 8 mile journey home.

At home I checked the coolant level. My driveway slopes downwards slightly so coolant was not level in expansion tank but it was well between the low and high levels, slightly nearer high in fact.

Anyone seen this before? Hopefully just a glitch but maybe a sensor going bad?
I have the same symptoms since august. First the warning light came on at seldom times, later it showed more and more often. For last two months the light is constantly lit on. I took the car to service and they said that something is wrong with one of the two cooling pumps - they didn't investigate which one, they ordered both for replacement. I will have replaced them on next thursday. I hope that it will solve the problem because the icon is very annoying - hiding information (e.g. navigaton data) all the time.
 

· Registered
Ioniq EV Premium SE 38.3kWh
Joined
·
109 Posts
Discussion Starter · #4 ·
Interesting. Yes I've 38kw too. Just topped 20500 miles, this was first time I've seen this. I'll keep an eye on it see if it happens again.
 

· Registered
Ioniq EV Premium SE 38.3kWh
Joined
·
109 Posts
Discussion Starter · #5 ·
I have the same symptoms since august. First the warning light came on at seldom times, later it showed more and more often. For last two months the light is constantly lit on. I took the car to service and they said that something is wrong with one of the two cooling pumps - they didn't investigate which one, they ordered both for replacement. I will have replaced them on next thursday. I hope that it will solve the problem because the icon is very annoying - hiding information (e.g. navigaton data) all the time.
Thanks for the information. If it persists I'll get the dealer to look into it, will mention the cooling pumps.
 

· Registered
Joined
·
64 Posts
I hope the coolant warning problem is now solved for my car. There was some kind of debris in the cooling system. The system has been drained and washed with water and compressed air. The technician said, there had been a fistful of very thick/gelatinous substance.

If I understood correctly, the Hyundai has now this issue in their knowledge base.

I heared at different, unconnected occasion, that this could happen because of mixing different types of coolant. But this was not verified with Hyundai.
 

· Registered
Ioniq EV Premium SE 38.3kWh
Joined
·
109 Posts
Discussion Starter · #7 ·
Mine has stopped for the last few weeks, and I had forgotten about it, but I got one warning over the weekend that cleared on restarting the car and didn't repeat. I'll probably get it booked in and looked at after Christmas.
 

· Registered
Joined
·
23 Posts
I’m having same problem. dealer replaced both pumps, flushed coolant multiple times and replaced the coolant with fresh coolant. It was fine when I drove of, but now a few days later it’s coming on again.
 

· Registered
Red 2019 Ioniq 38 Premium EV
Joined
·
998 Posts
Vauxhall Amperas have had a similar problem, message "Service High Voltage Coolant System" message & engine warning lights comes up. Those cars are out of warranty, and it's often a false alarm where the level-sensor clipped to bottom of the plastic reservoir fails. Common fault apparently, but only a Vx dealer can clear this error from the OBDII list so costs $$$ of course. The workaround is to unclip the sensor & bin it, replacing it with a 24 kOhm resistor. This avoids dealer bills, but you just have to keep an eye on the level yourself.
You can see pics & read about it here: Oh no! Just got the 'Service high voltage charging...

Might be worth asking the dealer if the fault you're getting comes from one of these things, and insisting they change the sensor if so. It's a cheap item, and on the Ampera at least it doesn't go into the fluid, so no messy/expensive drain/refill needed.
 

· Registered
Ioniq EV Premium SE 38.3kWh
Joined
·
109 Posts
Discussion Starter · #12 ·
Ok, so here's the update so far.

I took the car into Hyundai Mansfield yesterday. They confirmed later that day that they had reproduced the fault, bit it was taking longer to diagnose than anticipated. They've kept the car for a second day now, and are completing further diagnostics to identify exactly what has failed. They are going to return the car to me this afternoon (hopefully) then order replacement parts and book it in for 2 days to complete the repair.

I'll try and find out what they conclude has failed and report back here when I do.
 

· Registered
Ioniq EV Premium SE 38.3kWh
Joined
·
109 Posts
Discussion Starter · #14 ·
I suspect the flushing would be more to do with contaminants, which would be affecting the sensor readings. I'm guessing though, not my area of expertise.
 

· Registered
Joined
·
3 Posts
Good morning/evening all!
I am suffering exactly the same issue with this Coolant Warning, I have an Ioniq 2020 38KWh.
My unit was in the service center for 10 days and it hasn't be possible to solve the issue. They have flushed the coolant several times, they replaced the high voltage battery and the warning stills show up frequently.

I read all your comments but I want to do the qiestion, Have you gotten the warning resolved?

Thanks in advance.
Alejandro. In Costa Rica.
 

· Registered
Ioniq EV Premium SE 38.3kWh
Joined
·
109 Posts
Discussion Starter · #16 ·
Hi Alejandro

Yes mine was sorted out after a week in the garage. Looking at the job sheet they flushed the system and replaced the coolant. So far, after a few days driving, it hasn't reappeared, bit I'll be keeping an eye on it from now on.
 

· Registered
Joined
·
3 Posts
Hi Alejandro

Yes mine was sorted out after a week in the garage. Looking at the job sheet they flushed the system and replaced the coolant. So far, after a few days driving, it hasn't reappeared, bit I'll be keeping an eye on it from now on.
Thanks for replying this fast Martin!
Hopefully it has really been resolved in your case, I'll need to bring the car again this week. I'll keep the post updated.

Rgds.
Alejandro.
 

· Registered
Joined
·
64 Posts
Good morning/evening all!
I am suffering exactly the same issue with this Coolant Warning, I have an Ioniq 2020 38KWh.
My unit was in the service center for 10 days and it hasn't be possible to solve the issue. They have flushed the coolant several times, they replaced the high voltage battery and the warning stills show up frequently.

I read all your comments but I want to do the qiestion, Have you gotten the warning resolved?

Thanks in advance.
Alejandro. In Costa Rica.
I haven't got any warning after flushing and cleaning the system. They also replaced the main battery then (due to recall) but this was not connected with that warning light.
 

· Registered
Joined
·
3 Posts
I haven't got any warning after flushing and cleaning the system. They also replaced the main battery then (due to recall) but this was not connected with that warning light.
Thank you Vitro!
I'll bring the input to the service center here. They said they did that several times... however I'll bring that up.

Thanks again.
Alejandro.
 

· Registered
Joined
·
1 Posts
Just started my car and as I drove off got a yellow icon taking up the whole instrument display saying "refill coolant". Couldn't dismiss it from the display, would reappear after a few seconds. Car was serviced 5000 miles ago so should be in good condition.

A few minutes down the road I reached red traffic signals, so I turned off the car while waiting, then turned it on again. Message did not repeat for the rest of the 8 mile journey home.

At home I checked the coolant level. My driveway slopes downwards slightly so coolant was not level in expansion tank but it was well between the low and high levels, slightly nearer high in fact.

Anyone seen this before? Hopefully just a glitch but maybe a sensor going bad?
I have a20 Ioniq ev my coolant light just came on as yours did about to check it and if needed what type of coolant is needed thanks in advance
 
1 - 20 of 202 Posts
Top